Access Restriction Bypass Affecting github.com/sourcegraph/sourcegraph/cmd/frontend/graphqlbackend Open this link in a new tab package, versions <3.33.2


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMSOURCEGRAPHSOURCEGRAPHCMDFRONTENDGRAPHQLBACKEND-2319818

  • published

    14 Dec 2021

  • disclosed

    14 Dec 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/sourcegraph/sourcegraph/cmd/frontend/graphqlbackend to version 3.33.2 or higher.

Overview

github.com/sourcegraph/sourcegraph/cmd/frontend/graphqlbackend is a code search and navigation engine.

Affected versions of this package are vulnerable to Access Restriction Bypass. Strings in private source code could be guessed by an authenticated but unauthorized actor. This issue affects the Saved Searches and Code Monitoring features. A successful attack would require an authenticated bad actor to create many Saved Searches or Code Monitors to receive confirmation that a specific string exists. This could allow an attacker to guess formatted tokens in source code, such as API keys.

References