Improper Input Validation Affecting github.com/spiffe/spire/pkg/common/idutil Open this link in a new tab package, versions <0.11.3 >=0.12.0 <0.12.1


0.0
low
  • Attack Complexity

    High

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMSPIFFESPIREPKGCOMMONIDUTIL-1083206

  • published

    7 Mar 2021

  • disclosed

    7 Mar 2021

  • credit

    c53robin

How to fix?

Upgrade github.com/spiffe/spire/pkg/common/idutil to version 0.11.3, 0.12.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation the aws_iid Node Attestor improperly normalizes the path provided through the agent ID templating feature, which may allow the issuance of an arbitrary SPIFFE ID within the same trust domain. This is possible if the attacker controls the value of an EC2 tag prior to attestation, and the attestor is configured for agent ID templating where the tag value is the last element in the path.