Improper Input Validation Affecting github.com/sylabs/singularity/internal/app/singularity package, versions <3.6.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.1% (42nd percentile)
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMSYLABSSINGULARITYINTERNALAPPSINGULARITY-2322174
  • published 21 Dec 2021
  • disclosed 20 Dec 2021
  • credit Tru Huynh

How to fix?

Upgrade github.com/sylabs/singularity/internal/app/singularity to version 3.6.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation which can lead to running SIF containers that include unsigned, or modified objects.