Privilege Escalation Affecting github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity package, versions >=3.1.0 <3.2.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMSYLABSSINGULARITYINTERNALPKGRUNTIMEENGINESSINGULARITY-174726
  • published 4 Jul 2019
  • disclosed 14 May 2019
  • credit Unknown

How to fix?

Upgrade github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity to version 3.2.0 or higher.

Overview

github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity is an an open source container platform designed to be simple, fast, and secure.

Affected versions of this package are vulnerable to Privilege Escalation. An attacker with local or network access to the host system (e.g. ssh) may be allowed to edit files within /run/singularity/instances/sing/<user>/<instance>. This is due to insecure permissions handling.