Cross-site Request Forgery (CSRF) Affecting github.com/uadmin/uadmin package, versions <0.5.0


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMUADMINUADMIN-597188

  • published

    3 Aug 2020

  • disclosed

    3 Aug 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/uadmin/uadmin to version 0.5.0 or higher.

Overview

github.com/uadmin/uadmin is a fully loaded web framework for Golang.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). CSRF tokens were found to not exist within multiple areas of uadmin.