Arbitrary File Read Affecting github.com/ystia/yorc/v4/helper/sshutil package, versions >=4.0.0-M1 <4.0.0-M3 <3.2.4


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMYSTIAYORCV4HELPERSSHUTIL-1290062

  • published

    6 May 2021

  • disclosed

    6 May 2021

  • credit

    loicalbertin

How to fix?

Upgrade github.com/ystia/yorc/v4/helper/sshutil to version 4.0.0-M3, 3.2.4 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary File Read. A vulnerability exists which allows an attacker to read the content of a file stored on Yorc host by pretending it is an ssh key, leading to the contents of the referenced file being exposed in logs.