Information Disclosure Affecting go.elastic.co/apm package, versions <1.11.0


0.0
low

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    User Interaction Required
Expand this section
NVD
2.4 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GOELASTICCOAPM-1083947
  • published 11 Feb 2021
  • disclosed 11 Feb 2021
  • credit Unknown

How to fix?

Upgrade go.elastic.co/apm to version 1.11.0 or higher.

Overview

Affected versions of this package are vulnerable to Information Disclosure. The Elastic APM agent for Go can leak sensitive HTTP header information when logging the details during an application panic. Normally, the APM agent will sanitize sensitive HTTP header details before sending the information to the APM server. During an application panic it is possible the headers will not be sanitized before being sent.