Improper Input Validation Affecting package, versions >=2.0.0 <2.16.11 >=3.0.0 <3.3.2

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    18 Sep 2020

  • disclosed

    18 Sep 2020

  • credit


How to fix?

Upgrade to version 2.16.11, 3.3.2 or higher.

Overview is a package manager for kubernetes.

Affected versions of this package are vulnerable to Improper Input Validation. There is a bug in which the alias field on a Chart.yaml is not properly sanitized. This could lead to the injection of unwanted information into a chart.