Arbitrary Code Execution Affecting package, versions <2.16.11 <3.3.2



    Attack Complexity High
    User Interaction Required
    Scope Changed

    Threat Intelligence

    EPSS 0.07% (31st percentile)
Expand this section
4.7 medium
Expand this section
3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 18 Sep 2020
  • disclosed 18 Sep 2020
  • credit Unknown

How to fix?

Upgrade to version 2.16.11, 3.3.2 or higher.

Overview is a package manager for Kubernetes.

Affected versions of this package are vulnerable to Arbitrary Code Execution. A Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection).