Improper Input Validation Affecting helm.sh/helm/v3/pkg/plugin Open this link in a new tab package, versions >=2.0.0 <2.16.11 >=3.0.0 <3.3.2


0.0
low
  • Attack Complexity

    High

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-HELMSHHELMV3PKGPLUGIN-1083978

  • published

    18 Sep 2020

  • disclosed

    18 Sep 2020

  • credit

    Unknown

How to fix?

Upgrade helm.sh/helm/v3/pkg/plugin to version 2.16.11, 3.3.2 or higher.

Overview

helm.sh/helm/v3/pkg/plugin is a package manager for Kubernetes.

Affected versions of this package are vulnerable to Improper Input Validation. Plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behaviour, such as duplicating the name of another plugin or spoofing the output to helm --help.