Incorrect Access Control Affecting istio.io/istio/pilot/pkg/networking/plugin/mixer package, versions >=1.1.0 <1.1.7


0.0
critical
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-ISTIOIOISTIOPILOTPKGNETWORKINGPLUGINMIXER-1040846

  • published

    6 Jun 2019

  • disclosed

    17 May 2019

  • credit

    Haim Helman

How to fix?

Upgrade istio.io/istio/pilot/pkg/networking/plugin/mixer to version 1.1.7 or higher.

Overview

istio.io/istio/pilot/pkg/networking/plugin/mixer is an open platform to connect, manage, and secure microservices.

Affected versions of this package are vulnerable to Incorrect Access Control. One will be vulnerable if the following conditions are all true:

  1. NOT using HTTP, HTTP/2, or gRPC protocols.

  2. A mixer adapter (e.g., Deny Checker, List Checker) is used to provide authorization for your backend TCP service.

  3. disablePolicyChecks is set to false. To check that use the following command: kubectl -n istio-system get cm istio -o jsonpath="{@.data.mesh}" | grep disablePolicyChecks