Improper Input Validation Affecting k8s.io/apimachinery package, versions >=1.0.0 <1.13.12 >=1.14.0 <1.14.8 >=1.15.0 <1.15.5 >=1.16.0 <1.16.2


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-K8SIOAPIMACHINERY-1050878
  • published 13 Dec 2020
  • disclosed 13 Dec 2020
  • credit Unknown

How to fix?

Upgrade k8s.io/apimachinery to version 1.13.12, 1.14.8, 1.15.5, 1.16.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. It allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable.