Privilege Escalation Affecting k8s.io/apimachinery/pkg/util/proxy package, versions <0.19.0-rc.1


0.0
medium

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity High
    Privileges Required High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
6.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-K8SIOAPIMACHINERYPKGUTILPROXY-590104
  • published 16 Jul 2020
  • disclosed 15 Jul 2020
  • credit Unknown

How to fix?

Upgrade k8s.io/apimachinery/pkg/util/proxy to version 0.19.0-rc.1 or higher.

Overview

k8s.io/apimachinery/pkg/util/proxy is a package that provides transport and upgrade support for proxies.

Affected versions of this package are vulnerable to Privilege Escalation. If an attacker is able to intercept certain requests to the Kubelet, they can send a redirect response that may be followed by a client using the credentials from the original request. This can lead to compromise of other nodes.