Privilege Escalation Affecting k8s.io/kube-proxy package, versions >1.18.0 <1.18.4 >1.17.0 <1.17.7 >0.0.0 <1.16.11
Proof of concept
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
9 Jul 2020
8 Jul 2020
How to fix?
k8s.io/kube-proxy to version 1.18.4, 1.17.7, 1.16.11 or higher.
k8s.io/kube-proxy is a Package app does all of the work necessary to configure and run a Kubernetes app process.
Affected versions of this package are vulnerable to Privilege Escalation. A flaw was found in Kubernetes that allows attackers on adjacent networks to reach services exposed on localhost ports, previously thought to be unreachable. This flaw allows an attacker to gain privileges or access confidential information for any services listening on localhost ports that are not protected by authentication.