Access Restriction Bypass Affecting k8s.io/kubernetes/pkg/apis/apps/validation Open this link in a new tab package, versions <1.21.0-rc.0


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Privileges Required

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPKGAPISAPPSVALIDATION-1246528

  • published

    15 Apr 2021

  • disclosed

    14 Apr 2021

  • credit

    Unknown

How to fix?

Upgrade k8s.io/kubernetes/pkg/apis/apps/validation to version 1.21.0-rc.0 or higher.

Overview

k8s.io/kubernetes/pkg/apis/apps/validation is a Kubernetes, also known as K8s, is an open source system for managing containerized applications across multiple hosts. It provides basic mechanisms for deployment, maintenance, and scaling of applications.

Affected versions of this package are vulnerable to Access Restriction Bypass. Validating Admission Webhook does not observe some previous fields. A vulnerability was found in kube-apiserver that could allow node updates to bypass a Validating Admission Webhook. The highest threat from this vulnerability is to integrity and availability.