Improper Input Validation Affecting k8s.io/kubernetes/pkg/apis/core/validation Open this link in a new tab package, versions >=1.21.0 <1.21.1 >=1.20.0 <1.20.7 >=1.19.0 <1.19.11 <1.18.19
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
19 May 2021
12 May 2021
The Kubernetes Product Security Committee
How to fix?
k8s.io/kubernetes/pkg/apis/core/validation to version 1.21.1, 1.20.7, 1.19.11, 1.18.19 or higher.
Affected versions of this package are vulnerable to Improper Input Validation. A security issue was discovered in Kubernetes where an authorized user may be able to redirect traffic to private networks on a Node. An untrusted user could exploit this by creating or modifying EndpointSlices to point to localhost or link-local addresses.