Improper Input Validation Affecting package, versions >=1.21.0 <1.21.1 >=1.20.0 <1.20.7 >=1.19.0 <1.19.11 <1.18.19

  • Attack Complexity


  • Privileges Required


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    19 May 2021

  • disclosed

    12 May 2021

  • credit

    The Kubernetes Product Security Committee

How to fix?

Upgrade to version 1.21.1, 1.20.7, 1.19.11, 1.18.19 or higher.


Affected versions of this package are vulnerable to Improper Input Validation. A security issue was discovered in Kubernetes where an authorized user may be able to redirect traffic to private networks on a Node. An untrusted user could exploit this by creating or modifying EndpointSlices to point to localhost or link-local addresses.