Improper Input Validation Affecting k8s.io/kubernetes/pkg/apis/discovery/validation Open this link in a new tab package, versions >=1.21.0 <1.21.1 >=1.20.0 <1.20.7 >=1.19.0 <1.19.11 <1.18.19


0.0
low
  • Attack Complexity

    Low

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPKGAPISDISCOVERYVALIDATION-1295564

  • published

    19 May 2021

  • disclosed

    12 May 2021

  • credit

    The Kubernetes Product Security Committee

How to fix?

Upgrade k8s.io/kubernetes/pkg/apis/discovery/validation to version 1.21.1, 1.20.7, 1.19.11, 1.18.19 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. A security issue was discovered in Kubernetes where an authorized user may be able to redirect traffic to private networks on a Node. An untrusted user could exploit this by creating or modifying EndpointSlices to point to localhost or link-local addresses.