Improper Input Validation Affecting k8s.io/kubernetes/pkg/apiserver package, versions >=1.0.0 <1.13.12 >=1.14.0 <1.14.8 >=1.15.0 <1.15.5 >=1.16.0 <1.16.2


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPKGAPISERVER-1050879

  • published

    13 Dec 2020

  • disclosed

    13 Dec 2020

  • credit

    Unknown

How to fix?

Upgrade k8s.io/kubernetes/pkg/apiserver to version 1.13.12, 1.14.8, 1.15.5, 1.16.2 or higher.

Overview

k8s.io/kubernetes/pkg/apiserver is a Production-Grade Container Scheduling and Management.

Affected versions of this package are vulnerable to Improper Input Validation. It allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable.