Symlink Attack Affecting k8s.io/kubernetes/pkg/kubectl/cmd/cp package, versions <1.11.9 >=1.12.0 <1.12.7 >=1.13.0 <1.13.5


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPKGKUBECTLCMDCP-174801

  • published

    2 Apr 2019

  • disclosed

    6 Mar 2019

  • credit

    Unknown

How to fix?

Upgrade k8s.io/kubernetes/pkg/kubectl/cmd/cp to version 1.11.9, 1.12.7, 1.13.5 or higher.

Overview

k8s.io/kubernetes/pkg/kubectl/cmd/cp is a Production-Grade Container Scheduling and Management.

Affected versions of this package are vulnerable to Symlink Attack via the kubectl cp command. It could allow writing files to any path on the user’s machine when 'kubectl cp' is called, limited only by the system permissions of the local user.