Credential Exposure Affecting k8s.io/kubernetes/pkg/volume/cephfs Open this link in a new tab package, versions <1.18.0


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPKGVOLUMECEPHFS-1015598

  • published

    24 Jul 2020

  • disclosed

    24 Jul 2020

  • credit

    Unknown

How to fix?

Upgrade k8s.io/kubernetes/pkg/volume/cephfs to version 1.18.0 or higher.

Overview

k8s.io/kubernetes/pkg/volume/cephfs is a package that contains the internal representation of Ceph file system (CephFS) volumes.

Affected versions of this package are vulnerable to Credential Exposure. The Kubernetes kube-controller-manager is vulnerable to a credential leakage via error messages in mount failure logs and events for AzureFile and CephFS volumes.