Server Side Request Forgery (SSRF) Affecting k8s.io/kubernetes/pkg/volume/quobyte package, versions >=1.18.0 <1.18.1 >=1.17.0 <1.17.4 >=1.16.0 <1.16.9 <1.15.12


0.0
medium

Snyk CVSS

    Attack Complexity High
    Scope Changed
    Confidentiality High
Expand this section
NVD
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-K8SIOKUBERNETESPKGVOLUMEQUOBYTE-575596
  • published 10 Jul 2020
  • disclosed 5 Jun 2020
  • credit Unknown

How to fix?

Upgrade k8s.io/kubernetes/pkg/volume/quobyte to version 1.18.1, 1.17.4, 1.16.9, 1.15.12 or higher.

Overview

k8s.io/kubernetes/pkg/volume/quobyte is a contains the internal representation of Quobyte volumes.

Affected versions of this package are vulnerable to Server Side Request Forgery (SSRF). There exists a Server Side Request Forgery (SSRF) vulnerability in kube-controller-manager that allows certain authorized users to leak up to 500 bytes of arbitrary information from unprotected endpoints within the master's host network (such as link-local or loopback services).

An attacker with permissions to create a pod with certain built-in Volume types (GlusterFS, Quobyte, StorageOS, ScaleIO) or permissions to create a StorageClass can cause kube-controller-manager to make GET requests or POST requests without an attacker controlled request body from the master's host network.

References