Privilege Escalation Affecting k8s.io/kubernetes/plugin/pkg/admission/security/podsecuritypolicy Open this link in a new tab package, versions >=1.5.0 <1.5.5


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-K8SIOKUBERNETESPLUGINPKGADMISSIONSECURITYPODSECURITYPOLICY-174813

  • published

    1 Mar 2017

  • disclosed

    1 Mar 2017

  • credit

    Unknown

How to fix?

Upgrade k8s.io/kubernetes/plugin/pkg/admission/security/podsecuritypolicy to version 1.5.5 or higher.

Overview

k8s.io/kubernetes/plugin/pkg/admission/security/podsecuritypolicy is a PodSecurityPolicy admission plugin for Kubernetes.

Affected versions of this package are vulnerable to Privilege Escalation resulting in the ability to make use of any existing PodSecurityPolicy object.