Privilege Escalation Affecting Open this link in a new tab package, versions <1.10.11 >=1.11.0 <1.11.5 >=1.12.0 <1.12.3

  • Exploit Maturity


  • Attack Complexity


  • Confidentiality


  • Integrity


  • Availability


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    10 Dec 2018

  • disclosed

    5 Dec 2018

  • credit

    Jordan Liggitt

How to fix?

Upgrade to version 1.10.11, 1.11.5, 1.12.3 or higher.

Overview is a package that provides transport and upgrade support for proxies.

Affected versions of this package are vulnerable to Privilege Escalation. Incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.