Insecure Permissions Affecting kubevirt.io/kubevirt/pkg/cloud-init package, versions <0.26.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-KUBEVIRTIOKUBEVIRTPKGCLOUDINIT-1297174
  • published 28 May 2021
  • disclosed 28 May 2021
  • credit Unknown

How to fix?

Upgrade kubevirt.io/kubevirt/pkg/cloud-init to version 0.26.0 or higher.

Overview

kubevirt.io/kubevirt/pkg/cloud-init is a Kubernetes Virtualization API and runtime in order to define and manage virtual machines.

Affected versions of this package are vulnerable to Insecure Permissions. A flaw was found in the KubeVirt main virt-handler versions before 0.26.0 regarding the access permissions of virt-handler. An attacker with access to create VMs could attach any secret within their namespace, allowing them to read the contents of that secret.