Improper Input Validation Affecting coherence package, versions <0.5.2



    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.05% (21st percentile)
Expand this section
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-HEX-COHERENCE-1086567
  • published 18 Mar 2021
  • disclosed 2 Aug 2017
  • credit Griffin Byatt

How to fix?

Upgrade coherence to version 0.5.2 or higher.


Affected versions of this package are vulnerable to Improper Input Validation. A "mass assignment"-like vulnerability was discovered. In particular, registration endpoints (e.g., creating, editing, updating), allow users to update any coherence_fields. This means that, among other issues, users can automatically confirm their accounts by sending the confirmed_at parameter with their registration request. A malicious user, for example, could exploit this vulnerability to register a user and add assign it admin privileges.