Improper Input Validation Affecting ecto package, versions <2.2.1


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-HEX-ECTO-1088059
  • published 30 Mar 2021
  • disclosed 27 Aug 2017
  • credit Unknown

Introduced: 27 Aug 2017

CVE NOT AVAILABLE CWE-20 Open this link in a new tab

How to fix?

Upgrade ecto to version 2.2.1 or higher.

Overview

ecto is a toolkit for data mapping and language integrated query for Elixir.

Affected versions of this package are vulnerable to Improper Input Validation. Affected versions of ecto do raise an error when non-explicit nil comparisons are made (as opposed to being checked with is_nil). An attacker could pass a field as nil (e.g. a token field) and force the application to run a query it was not intended to.

CVSS Scores

version 3.1
Expand this section

Snyk

7.3 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    Low