HTTP Header Injection Affecting plug Open this link in a new tab package, versions >=1.3.0 <1.3.5 >=1.2.0-rc.0 <1.2.5 >=1.1.0 <1.1.9 <1.0.6


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-HEX-PLUG-1088060

  • published

    30 Mar 2021

  • disclosed

    17 Apr 2017

  • credit

    Unknown

How to fix?

Upgrade plug to version 1.3.5, 1.2.5, 1.1.9, 1.0.6 or higher.

Overview

plug is a specification and conveniences for composable modules between web applications.

Affected versions of this package are vulnerable to HTTP Header Injection. Cookie headers are not validated in Plug.Conn. This allows an attacker that sends a crafted value as the cookie to inject other headers.

References