Improper Verification of Cryptographic Signature Affecting cn.fxbin.bubble:bubble-fireworks-plugin-token Open this link in a new tab package, versions [0,2021.5)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-CNFXBINBUBBLE-1300551

  • published

    6 Jun 2021

  • disclosed

    6 Jun 2021

  • credit

    intrigus-lgtm

How to fix?

Upgrade cn.fxbin.bubble:bubble-fireworks-plugin-token to version 2021.5 or higher.

Overview

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature due to improper JWT signature verification, which may allow forgery.

References