Improper Authorization Affecting com.blackducksoftware.integration:blackduck-hub Open this link in a new tab package, versions [,4.0.1)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMBLACKDUCKSOFTWAREINTEGRATION-32406

  • published

    4 Jul 2018

  • disclosed

    5 Jun 2018

  • credit

    Thomas de Grenier de Latour

How to fix?

Upgrade com.blackducksoftware.integration:blackduck-hub to version 4.0.1 or higher.

Overview

com.blackducksoftware.integration:blackduck-hub provides ability to run a scan using the BD Hub CLI on build input and/or output.

Affected versions of this package are vulnerable to Improper Authorization via the PostBuildScanDescriptor.java method. User with Overall/Read permission could read and write the Black Duck Hub plugin configuration.