Information Exposure Affecting com.bmuschko:gradle-vagrant-plugin package, versions [, 3.0.0)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Scope Changed
    Confidentiality High
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-COMBMUSCHKO-1083283
  • published 9 Mar 2021
  • disclosed 9 Mar 2021
  • credit Unknown

How to fix?

Upgrade com.bmuschko:gradle-vagrant-plugin to version 3.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure due to the logging of the system environment variables.

When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors.

References