Improper Control of Generation of Code Affecting com.cronutils:cron-utils package, versions [0,9.1.3)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMCRONUTILS-1045837

  • published

    26 Nov 2020

  • disclosed

    24 Nov 2020

  • credit

    Unknown

How to fix?

Upgrade com.cronutils:cron-utils to version 9.1.3 or higher.

Overview

com.cronutils:cron-utils is a Java library to parse, migrate and validate crons as well as describe them in human readable language.

Affected versions of this package are vulnerable to Improper Control of Generation of Code. A template injection vulnerability is present in previous versions of cron-utils. This enables attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Only projects using the @Cron annotation to validate untrusted Cron expressions are affected.