Improper Input Validation Affecting com.ctrip.framework.apollo:apollo-adminservice Open this link in a new tab package, versions [,1.7.1)


0.0
high
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMCTRIPFRAMEWORKAPOLLO-1015595

  • published

    4 Oct 2020

  • disclosed

    2 Oct 2020

  • credit

    Unknown

How to fix?

Upgrade com.ctrip.framework.apollo:apollo-adminservice to version 1.7.1 or higher.

Overview

com.ctrip.framework.apollo:apollo-adminservice is a reliable configuration management system.

Affected versions of this package are vulnerable to Improper Input Validation. Malicious hackers may access apollo-adminservice apis directly to access/edit the application's configurations if users expose it to the internet.

References