URL Injection Affecting com.floragunn:search-guard-kibana-plugin package, versions [,6.3.0-16) [6.3.1-14,6.3.1-16) [6.3.2-14,6.3.2-16) [6.4.0-14,6.4.0-16) [6.4.1-15,6.4.1-16) [6.4.2-15,6.4.2-16) [6.4.3-15,6.4.3-16)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMFLORAGUNN-174181

  • published

    9 Apr 2019

  • disclosed

    9 Apr 2019

  • credit

    Unknown

How to fix?

Upgrade com.floragunn:search-guard-kibana-plugin to version 6.3.0-16, 6.3.1-16, 6.3.2-16, 6.4.0-16, 6.4.1-16, 6.4.2-16, 6.4.3-16 or higher.

Overview

com.floragunn:search-guard-kibana-plugin is a Search Guard Kibana Plugin for Elasticsearch 6.

Affected versions of this package are vulnerable to URL Injection. The code allows URL injection for login redirects on the login page when basePath is set.