Access Control Bypass Affecting com.floragunn:search-guard-6 Open this link in a new tab package, versions [6.0.0-17.beta1,6.4.0-24.3) [6.4.1-23.1,6.4.1-24.3) [6.4.2-23.1,6.4.2-24.3) [6.4.3-23.1,6.4.3-24.3) [6.5.1-23.2,6.5.1-24.3) [6.5.2-23.2,6.5.2-24.3) [6.5.3-23.2,6.5.3-24.3) [6.5.4-24.0,6.5.4-24.3) [6.6.0-24.1,6.6.0-24.3) [6.6.1-24.1,6.6.1-24.3) [6.6.2-24.2,6.6.2-24.3)


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMFLORAGUNN-459305

  • published

    13 Aug 2019

  • disclosed

    13 Aug 2019

  • credit

    floragunn

How to fix?

Upgrade com.floragunn:search-guard-6 to version 6.4.0-24.3, 6.4.1-24.3, 6.4.2-24.3, 6.4.3-24.3, 6.5.1-24.3, 6.5.2-24.3, 6.5.3-24.3, 6.5.4-24.3, 6.6.0-24.3, 6.6.1-24.3, 6.6.2-24.3 or higher.

Overview

com.floragunn:search-guard-6 is a package to provide access control related features for Elasticsearch 6

Affected versions of this package are vulnerable to Access Control Bypass. When Cross Cluster Search (CCS) is enabled, authenticated users can gain read access to data they are not authorized to see or access.