Improper Certificate Validation Affecting com.github.kevinsawicki:http-request package, versions [0,]


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-COMGITHUBKEVINSAWICKI-451698
  • published 23 Jul 2019
  • disclosed 23 Jul 2019
  • credit Unknown

How to fix?

There is no fixed version for com.github.kevinsawicki:http-request.

Overview

com.github.kevinsawicki:http-request is a simple convenience library for making HTTP requests.

Affected versions of this package are vulnerable to Improper Certificate Validation. The software does not validate the SSL certificate during an HTTPS connection.