Arbitrary Code Execution Affecting com.googlecode.wicket-jquery-ui:wicket-jquery-ui-plugins Open this link in a new tab package, versions [6.0.0,6.29.1) [7.0.0, 7.10.1) [8.0.0-M1, 8.0.0-M9.2)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMGOOGLECODEWICKETJQUERYUI-32229

  • published

    25 Apr 2018

  • disclosed

    18 Apr 2018

  • credit

    Kamil Sevi

How to fix?

Upgrade com.googlecode.wicket-jquery-ui:wicket-jquery-ui-plugins to versions 6.29.1, 7.10.2, 8.0.0-M9.2 or higher.

Overview

com.googlecode.wicket-jquery-ui:wicket-jquery-ui-plugins is jQuery UI & Kendo UI integration in Wicket.

Affected versions of this package are vulnerable to Arbitrary Code Execution via the WYSIWYG editor.