Improper Authorization Affecting package, versions [,1.31.0)



    Attack Complexity High
    Confidentiality High
    Integrity High
Expand this section
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 3 Jul 2020
  • disclosed 3 Jul 2020
  • credit Stefán Freyr Stefánsson

How to fix?

Upgrade to version 1.31.0 or higher.

Overview is a powerful and easy-to-use Java library for the OAuth 1.0a and OAuth 2.0 authorization standards.

Affected versions of this package are vulnerable to Improper Authorization. PKCE support is not implemented in accordance with the RFC for OAuth 2.0 for Native Apps. Without the use of PKCE, the authorization code returned by an authorization server is not enough to guarantee that the client that issued the initial authorization request is the one that will be authorized. An attacker is able to obtain the authorization code using a malicious app on the client-side and use it to gain authorization to the protected resource.