Information Exposure Affecting com.liferay:com.liferay.portal.store.s3 Open this link in a new tab package, versions [0,2.0.48) [3.0.0,3.0.49) [4.0.0,4.0.32) [5.0.0,5.0.21)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMLIFERAY-1293219

  • published

    17 May 2021

  • disclosed

    17 May 2021

  • credit

    Unknown

How to fix?

Upgrade com.liferay:com.liferay.portal.store.s3 to version 2.0.48, 3.0.49, 4.0.32, 5.0.21 or higher.

Overview

com.liferay:com.liferay.portal.store.s3 is a portal for Liferay.

Affected versions of this package are vulnerable to Information Exposure via the Portal Store module. It does not obfuscate the S3 store's proxy password, which allows attackers to steal the proxy password via man-in-the-middle attacks or shoulder surfing.