Insufficiently Protected Credentials Affecting Open this link in a new tab package, versions [,2.7.3) [3.0.0,3.0.94) [4.0.0,4.0.57) [5.0.1,5.1.0)

  • Attack Complexity


  • Confidentiality


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    11 Jun 2020

  • disclosed

    11 Jun 2020

  • credit


How to fix?

Upgrade to version 2.7.3, 3.0.94, 4.0.57, 5.1.0 or higher.

Overview is an is designed to work within your existing business processes and technologies to build a custom solution that uniquely meets your need

Affected versions of this package are vulnerable to Insufficiently Protected Credentials. It does not sanitise the information returned by the DDMDataProvider API, which allows remote authenticated users to obtain the password to REST Data Providers.