Information Exposure Affecting com.liferay.portal:portal-impl Open this link in a new tab package, versions [,5.18.3)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMLIFERAYPORTAL-1293217

  • published

    17 May 2021

  • disclosed

    17 May 2021

  • credit

    Unknown

How to fix?

Upgrade com.liferay.portal:portal-impl to version 5.18.3 or higher.

Overview

com.liferay.portal:portal-impl is a Portal Impl

Affected versions of this package are vulnerable to Information Exposure in the JSON web services. It may provide overly verbose error messages, which allows remote attackers to use the contents of error messages to help launch another, more focused attacks via crafted inputs.