HTTP Response Splitting Affecting com.linecorp.armeria:armeria Open this link in a new tab package, versions [0.85.0, 0.97.0)


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMLINECORPARMERIA-536957

  • published

    8 Dec 2019

  • disclosed

    6 Dec 2019

  • credit

    Jonathan Leitschuh

How to fix?

Upgrade com.linecorp.armeria:armeria to version 0.97.0 or higher.

Overview

com.linecorp.armeria:armeria is an asynchronous HTTP/2 RPC/REST client/server library built on top of Java 8, Netty, Thrift and gRPC (armeria)

Affected versions of this package are vulnerable to HTTP Response Splitting. It allows remote attackers to inject arbitrary HTTP headers via CRLF sequences when unsanitized data is used to populate the headers of an HTTP response. This vulnerability has been patched in 0.97.0.