XML External Entity (XXE) Injection Affecting com.nimbusds:oauth2-oidc-sdk Open this link in a new tab package, versions [5.0, 8.36.2) [9.0, 9.3.1)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMNIMBUSDS-1243767

  • published

    7 Apr 2021

  • disclosed

    7 Apr 2021

  • credit

    Unknown

Introduced: 7 Apr 2021

CWE-611 Open this link in a new tab

How to fix?

Upgrade com.nimbusds:oauth2-oidc-sdk to version 8.36.2, 9.3.1 or higher.

Overview

Affected versions of this package are vulnerable to XML External Entity (XXE) Injection via the SAML2AssertionValidator method. Access to external entities was not disabled in XML parsing.