Improper Input Validation Affecting com.orientechnologies:orientdb-studio package, versions [,2.0.15) [2.1.0, 2.1.1)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMORIENTECHNOLOGIES-456072

  • published

    31 Jul 2019

  • disclosed

    21 Dec 2015

  • credit

    Unknown

How to fix?

Upgrade com.orientechnologies:orientdb-studio to version 2.0.15, 2.1.1 or higher.

Overview

com.orientechnologies:orientdb-studio is a web interface for OrientDB server.

Affected versions of this package are vulnerable to Improper Input Validation. It does not properly restrict use of FRAME elements, which makes it easier for remote attackers to conduct clickjacking attacks via a crafted web site.