SSL Certificate Bypass Affecting com.squareup.okhttp:okhttp package, versions [,2.7.4)


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMSQUAREUPOKHTTP-30380

  • published

    11 Feb 2016

  • disclosed

    11 Feb 2016

  • credit

    John Kozyrakis

How to fix?

Upgrade com.squareup.okhttp:okhttp to version 2.7.4 or higher.

Overview

com.squareup.okhttp:okhttp is an HTTP & HTTP/2 client for Android and Java applications

Affected versions of this package are vulnerable to SSL Certificate Bypass. It allows man-in-the-middle attackers to bypass certificate pinning by sending a certificate chain with a certificate from a non-pinned trusted CA and the pinned certificate.