Improper Verification of Cryptographic Signature Affecting com.starkbank.ellipticcurve:starkbank-ecdsa Open this link in a new tab package, versions [,1.0.1)


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMSTARKBANKELLIPTICCURVE-1913039

  • published

    9 Nov 2021

  • disclosed

    8 Nov 2021

  • credit

    NCC Group

How to fix?

Upgrade com.starkbank.ellipticcurve:starkbank-ecdsa to version 1.0.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature which may allow an attacker to forge signatures on arbitrary messages that will verify for any public key. This allows attackers to authenticate as any user within the platform.