Information Exposure Affecting com.tinfoilsecurity.plugins:tinfoil-scan Open this link in a new tab package, versions [,2.0)


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMTINFOILSECURITYPLUGINS-32447

  • published

    2 Aug 2018

  • disclosed

    30 Jul 2018

  • credit

    Viktor Gazdag

How to fix?

Upgrade com.tinfoilsecurity.plugins:tinfoil-scan to version 2.0 or higher.

Overview

com.tinfoilsecurity.plugins:tinfoil-scan allows you to run web security tests from the cloud using Tinfoil Security.

Affected verisons of this package are vulnerable to Information Exposure via the TinfoilScanRecorder.java method due to storing API Secret Key in plain text.