Improper Authorization Affecting com.yahoo.elide:elide-core Open this link in a new tab package, versions [,4.5.14)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMYAHOOELIDE-561583

  • published

    30 Mar 2020

  • disclosed

    30 Mar 2020

  • credit

    Unknown

How to fix?

Upgrade com.yahoo.elide:elide-core to version 4.5.14 or higher.

Overview

com.yahoo.elide:elide-core is a library that lets you stand up a GraphQL/JSON-API web service with minimal effort.

Affected versions of this package are vulnerable to Improper Authorization. An adversary can "guess and check" the value of a model field they do not have access to assuming they can read at least one other field in the model.