Insecure Cryptography Algorithm Affecting com.zeroc:icegrid Open this link in a new tab package, versions [0,3.7.5-rc0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-COMZEROC-1056905

  • published

    26 Jan 2021

  • disclosed

    8 Jan 2021

  • credit

    Unknown

Introduced: 8 Jan 2021

CWE-310 Open this link in a new tab

How to fix?

Upgrade com.zeroc:icegrid to version 3.7.5-rc0 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Cryptography Algorithm. It uses the MD5 algorithm which is considered insecure.