Insufficiently Protected Credentials Affecting de.tracetronic.jenkins.plugins:ecutest Open this link in a new tab package, versions [,2.24)


0.0
low
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-DETRACETRONICJENKINSPLUGINS-1062606

  • published

    20 Jan 2021

  • disclosed

    20 Jan 2021

  • credit

    Long Nguyen of Viettel Cyber Security

How to fix?

Upgrade de.tracetronic.jenkins.plugins:ecutest to version 2.24 or higher.

Overview

Affected versions of this package are vulnerable to Insufficiently Protected Credentials. TraceTronic ECU-TEST stores credentials unencrypted in its global configuration file. These credentials can be viewed by users with access to the Jenkins controller file system.