Cross-site Request Forgery (CSRF) Affecting de.tracetronic.jenkins.plugins:ecutest Open this link in a new tab package, versions [,2.4)


0.0
medium
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-DETRACETRONICJENKINSPLUGINS-32461

  • published

    2 Aug 2018

  • disclosed

    30 Jul 2018

  • credit

    Viktor Gazdag

How to fix?

Upgrade de.tracetronic.jenkins.plugins:ecutest to version 2.4 or higher.

Overview

de.tracetronic.jenkins.plugins:ecutest integrates Jenkins with ECU-TEST and generates reports on automated test execution.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the ATXPublisher.java class. It did not perform permission checks on a method implementing form validation. This form validation method did not require POST requests, resulting in a CSRF vulnerability.